解决提示需要 GLIBC_2.18 问题

warning: 这篇文章距离上次修改已过262天,其中的内容可能已经有所变动。

解决提示需要 GLIBC_2.18 问题

因为我这是linux,某些软件运行可能会提示需要 GLIBC_2.18

提示需要GLIBC_2.18提示需要GLIBC_2.18

当然,你可以使用下面的命令查看是否有GLIBC_2.18。

strings /usr/lib64/libc.so.6 | grep ^GLIBC_

检查是否安装GLIBC检查是否安装GLIBC

ps:mmp!就差2.18!

好吧,安!安装命令如下

Error:如果不懂请复制命令运行,注意检查不要复制错了!编译安装时间略长!请耐心等待。
#安装gcc和curl(一般默认都有,可以跳过)
sudo yum install gcc
sudo yum install curl

#获取glibc-2.18.tar.gz
curl -O http://ftp.gnu.org/gnu/glibc/glibc-2.18.tar.gz

#解压glibc-2.18源代码
tar zxf glibc-2.18.tar.gz

#进入目录
cd glibc-2.18/

#创建build目录
mkdir build
cd build/

#编译安装
../configure --prefix=/usr
make -j2
make install

OK,安装完毕

glibc-2.18安装成功glibc-2.18安装成功

最后修改于:2020年02月07日 12:54

添加新评论

* 已开启反垃圾保护,《隐私政策》